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SVY110 AutoCad Tutorial
Introduction

These pages are adapted from an on-line tutorial – the second tutorial can be found at: 

http://www2.ncsu.edu:8010/unity/lockers/project/graphicscourse/gc/acadtut/acadtut2000/tutor2Anew.html
I would also suggest taking a good look at
http://www.cadtutor.net/acad/acad2ki/draw/draw.html
for basic CAD drawing and,

http://www.cadtutor.net/acad/index.html
for other tutorials.

To Submit

Submit an A4 drawing of the ground floor of your house (or plan of your flat/apartment).  The plan should show the following items:

· External and internal walls

· Position of doors and windows

· Labeled rooms

· Dimensions for exterior

The drawing should be submitted on a suitably annotated drawing sheet (which you will create as part of this practical).  The drawing should be submitted by Friday 29th October to the coursework submission office, 2nd floor Cassie building.

This tutorial will familiarize you with some aspects of using AutoCAD and allow you to create a file that you can use as a border and titleblock for drawings you create later.
Spend time carefully reading the information in the tutorials, especially explanations of features in the AutoCAD program. A good grounding in the operations of this program will allow you to progress quicker and apply these concepts to new situations.
OBJECTIVES
At the end of this tutorial you will be able to:

1. locate, copy, and open a blank AutoCAD file that has been configured for your use;

2. draw lines using Absolute Coordinates and the OFFSET command;

3. add text to a drawing;

4. create a Block;

5. insert a Block into Layout (Paper) Space;

6. save a file for later use; and

7. print a drawing.

IMPORTANT INFORMATION:

This set of tutorials will explore some of the commands found in AutoCAD.

You will be shown how to perform a task once in the tutorial and then will be expected to use the information in the left panel to help you perform this task again. This system is designed to help you retain more of what you practice in the tutorials.

Read the information in the panel carefully and keep it visible as you work with a command. Spend some time trying to perform the task before you ask for help. You will learn more this way. 

Step 1

The next task you need to perform is to copy an AutoCAD file onto your user space.  The file is called startpage.dwg and is available from the student website at http://www.ceg.ncl.ac.uk/students (use your PC id and password to log onto the site)

Once you have saved it into a directory on your user space (H:\) double click it to start Autocad.

NOTE: If you are having difficulty getting the file to open, launch AutoCAD first, and then open the file inside of AutoCAD through the Open... command under the File Menu. When you open AutoCAD, a window will appear, the Active Assistant. To get rid of the Active Assistant, go to the right left corner of the Start strip at the bottom of the computer screen and find the Active Assistant icon [image: image1]. Click on this icon with the RIGHT mouse button and select EXIT on the pop-up menu that appears. If you later wish to reactivate the Active Assistant, you can access it again under the Help menu. 

The Startpage file is an empty (template) file that has been configured for your use. You will need the features that have been preset in this file to create drawings in several of the tutorials. Later, you will be shown how to configure a file from scratch.

Step 2

When the Startpage file opens, resize the AutoCAD window to fill the entire screen the same way you resized the browser window.

Now, you should use Save As... (under the File pull-down menu) to save the file under the name "classtemplate" (without the quotation marks). This will preserve the original file for future use.

Step 3

You will begin your familiarization with AutoCAD by examining the AutoCAD screen.

Look at FIGURE 1. This illustration labels the parts of the AutoCAD screen. Gradually you will be shown other elements of the program, but a basic familiarization will do for now.

[image: image2]
AutoCAD has a large Drawing Area where you construct your drawings or models. It has a Menu Bar with pull-down menus, and Tool Bar areas at the Top and Left side of the screen. The Layer Status Window indicates the current drawing layer, and the Status Line indicates the current status of certain AutoCAD configurations. The Cursor tracks the mouse location on the drawing area and changes shape during certain operations. The Command Prompt Line displays command options and is also the area that receives your typed responses. The UCS Icon indicates where you are in three dimensional space. The Layout buttons move you to Layout or PAPER Space for printing layouts. I will discuss more about Layout and PAPER Space later in the tutorial.

NOTE: The toolbars you have showing may not match the example in FIGURE 1. Toolbars can be added or removed through the Toolbars... option under the View Menu.

Tool buttons sometimes have "flyouts," which are additional tool buttons that appear when the Left mouse button is held down while the cursor is over a tool button icon with a flyout. You will recognize a flyout by the small triangle that appears in the lower right corner of a tool button.

	 To carry out actions in AutoCAD, you use AutoCAD COMMANDS. Commands can be activated in several ways:

1. through Pull-down MENUS,
2. through TOOL BARS, and

3. through TYPED commands.


For most of you, the use of Menus and Toolbars are not new. Frequently, you can use both of these methods to activate the same command. You also may be able to type the command in the Prompt Line Window. Some commands can only be typed. Most typed commands also have short-cut "aliases" of one or more letters. Using the aliases speeds up your work and is less tiring than using the mouse to select the commands on the toolbars and menus.

EXAMPLE:
To activate the Zoom command, you can type just the letter "z" at a Command: prompt and press Enter. When the next Zoom prompt reads: 

Specify corner of window, enter a scale factor (nX or nXP), or [All/Center/Dynamic/Extents/Left/Previous/Vmax/Window] <realtime>: 

you could type the letter "e" and then press Enter to choose the Extents option. You only have to type the Capital letter/s for each option, because the capital letters are the alias for the options. 

	The Prompt Line window is one of the most important locations on the AutoCAD screen. The prompt line is where command options will be displayed, where you will receive instructions, and where you respond to a Command: prompt. If you fail to respond to the prompts on this line, you will be unable to complete most tasks in AutoCAD. When the prompt Command: appears in this area, AutoCAD is ready to receive a new command.

Failure to read the command prompts will lead to frustration!! 


To begin your titleblock drawing, you will use the Line command. To activate this command, either locate the Line [image: image3]button on the Drawing toolbar and click on it with the Left Mouse button, or type a letter L ( the first letter in the word Line and the "alias" for the Line command) at the Command: prompt and press the Enter key.

NOTE: Typed commands and their aliases are NOT case-sensitive.

Look at the prompt line, which now asks Specify first point:. At this prompt, type 0,0 (with no spaces) and press the Enter Key or the Right mouse button. This is the beginning point for a line.

The numbers you enter are specifications on the X and Y axes. If you type 10,10, for instance, you are indicating a point that is 10 mm along the X-axis and 10 mm along the Y-axis. The Cartesian System (of X, Y, and Z axes) is one way that AutoCAD can locate points in a drawing. When AutoCAD asks for a position, use coordinates for that position by typing in the X and the Y value separated by a COMMA. See FIGURE 2, which illustrates that the concept is the same as plotting points on a XY graph.

Look again at the Prompt line, which now reads:
Specify next point or [Undo]:. Type 262,0 and press Enter to stop the line. Press Enter again to exit the Line command.

You have located the second end of the line, and a single line should appear on the screen, although it may not be located exactly where the line appears in FIGURE 3.
	NOTE: If you need to exit a command and return to a Command: prompt, press the Escape Key.


[image: image4]
FIGURE 3

If you are having difficulty finding the line that you just drew, type z (the "alias" for Zoom) at a Command: prompt and press Enter.
The prompt line will read: Specify corner of window, enter a scales factor (nX or nXP), or [All/Center/Dynamic/Extents/ Previous/Scale/Window] <realtime>:.
This prompt lists the Options that you can select under the Zoom command separated by "/" (slash) marks.

Realtime (the option in the < >) is the default option. If you press the Enter key without selecting a different option, this is the option that AutoCAD will use. Other options can be selected by typing the capital letters in the option's name on the prompt line.

Let's examine some of the options under this command.

In Realtime Zoom the cursor turns into a small magnifying glass [image: image5]. To zoom in or out, click the LEFT mouse button in the drawing area and drag the mouse up or down. To Exit Realtime Zoom, press the Esc key or depress and hold down the right mouse button in the drawing area until a pop-up menu appears. Select Exit on the pop-up menu.

Take a few seconds to try the Realtime Zoom option so that you can become comfortable with it.

To return to the full size view, type z (for Zoom) at a Command: prompt, press Enter, and then type a, for the All option. All displays the entire drawing limits on the screen.

A Window Zoom allows you to zoom to a specific area by using the mouse to select the diagonal corners of a rectangular selection "box" or window.

To Window Zoom command, move the cursor to a corner just outside of the area that you want to examine closer, and click the LEFT mouse button once and release it. This establishes the first corner of a selection rectangle that will be used to select the view. Now, without holding down the mouse button, slide the cursor to an opposite diagonal corner of the area you wish to examine. A rectangle that indicates the area you are selecting will appear as you drag the mouse. Click the LEFT mouse button again to indicate the end of the selection area. The area will enlarge to fill the AutoCAD drawing area. 

Try this Zoom option, and then use Zoom All to return to a normal view of the drawing area. 

You may want to use the scroll bars to position the single line you have created towards the bottom of the screen, since all of the lines we will add will be above this one.

	HELP NOTES:
1. If you make a mistake, are in the wrong menu, or need to exit a command, press the Esc (Escape) key to return to a Command: prompt.


2. If you need to remove a line or other element in AutoCAD, there are several ways you can accomplish this. One is to use the Undo command. To undo an action press the Enter Key or use the Esc key until the Command: prompt appears. Now, either type u and then press the Enter Key, or click on the Undo tool button [image: image6]. Typing u at a Command: prompt will undo the last thing you did after you press the Enter key. The Undo button, or typing undo at a Command: prompt, allows you to indicate the number of steps you wish AutoCAD to reverse.

Another way to eliminate an element is through the Erase command. To erase a line or other element in AutoCAD, click on the Erase button [image: image7], select Erase under the Modify pull-down menus, or type "e" (the "alias" for Erase) at a Command: prompt. AutoCAD will direct you to: Select objects:. With the cursor on top of the item you wish to erase, click the left mouse button (the item selected will change to a dotted line) and press the right mouse button or the Enter key. AutoCAD will display the prompt Select objects... a second time to allow you to add more items to your selection. Press Enter to end the selection process and press Enter again to remove the selected items and exit the command.
***TIME SAVER TIP: The RIGHT mouse button can be used as the Enter key.*** 


Now, you will use the Line command to add a second line. This line should start at 0 on the X-axis and 7 on the Y-axis and end at 262 on the X-axis and 7 on the Y-axis. See FIGURE 4.
[image: image8]
FIGURE 4

Press the Enter key again to exit the Line command, and return to a Command: prompt. Remember, when the prompt displays Command: AutoCAD is ready for a new command.

At the Command: prompt, type qsave and press the Enter Key, or select Save on the File pull-down menu. This will save the lines you have drawn in the classtemplate file. 

You should save after every 3 or 4 changes you make to your drawings.
Save often to avoid losing your work or you WILL regret it. This is the voice of experience!
Step 5
To add the third line, you will use the Offset command.

Read the information on the Offset command. This command can be activated by selecting Offset under the Modify Menu, typing offset at a Command: prompt, or by clicking on the Offset button [image: image9].

When the prompt reads Specify offset distance or [Through] <1.0000>, type 7 and Enter.

When the prompt reads Select object to offset or <exit>: click the left mouse button on the second (TOP) line you added (it will change into a dashed line to indicate that it is selected).

When the prompt reads Side to offset ?, click in the drawing area ABOVE this line. AutoCAD needs to know on which side of the original line to place the copy.

A new line, which is parallel and the same length, should appear above the original. See FIGURE 5. Press Enter again to return to a Command: prompt.

[image: image10]
FIGURE 5

HELP NOTES:
Remember, the RIGHT key on the mouse is the equivalent of pressing the Enter key and is frequently faster than using the Enter key.

Pressing Enter at a Command: prompt will activate the last command you used.

To exit a command and return to a Command: prompt, press the Esc key.

Use the Offset command again to add a line 186 mm above the last line you added.

You now have 4 lines. See FIGURE 6. 
If you cannot see all of your lines, use the All or Extents (zooms to the extent of the drawing) option under the Zoom command.

[image: image11]
FIGURE 6
Step 6
Now, you will add two more lines using Absolute Coordinates. This is the same method you used to add the first two lines of the titleblock.

Carefully read the information on Absolute Coordinates before adding these lines.

Now, draw a line that begins at a point that is 0 along the X-axis and 0 along the Y-axis (0,0) and ends at a point that is 0 along the X-axis and 200 along the Y-axis (0,200). Press Enter until you return to a Command: prompt. See FIGURE 7.
Add a second line that begins at a point 262 along the X and 0 along the Y and ends at a point 262 along the X and 200 along the Y. Your titleblock should now look like FIGURE 7.

Press Enter until you exit the Line command.

At the Command: prompt, type qsave and Enter, or select Save under the File menu.

[image: image12]
FIGURE 7
NOTE: 
Remember, another way to select the Line command is to type line or a single lowercase L at a Command: prompt.

Step 7
Your titleblock now needs short divider lines in the title bar area for the text blocks.

Restart the Line command.

Your first line should begin at 131,0 and end at 131,14.

Press Enter twice (to bring up the Line command again).

Your second line should begin at 70,0 and end at 70,7.

Return to a Command: prompt. Save.
Use Offset: [image: image13]to create a duplicate of the last line you drew and place it 131 mm to its right. See FIGURE 8.
[image: image14]
FIGURE 8
Step 8
It is time for you to add text to your titleblock. Before adding this text, you must change the Layer.

To change to a new layer, click on the arrow on the RIGHT end of the Layer Status Window, located at the top of the AutoCAD screen (see Figure below). Find the layer labeled Text, and click on the Layer Name (you may have to scroll to find this layer). The Text layer name should appear in the Layer Status Window when you are done. [image: image15]
Another way to change layers is through the Layer Properties Manager dialogue box. It can be selected by clicking on the Layer button [image: image16]. If you use the dialogue box to change the layer, use the Left mouse button to select the layer, the Current button, and OK to make the change. You must click on the Current button because there are multiple operations that you can perform in this dialogue box.

After you change the layer, look at Layer Status Window. Notice that the small square, next to the name, displays a color other than white. This color has been assigned to this layer, which means that anything drawn in this layer will be displayed on the screen in this color. The line colors also have a relationship to the thickness of the lines when printing, but we will get to that issue later.
Are you ready to add text? Here goes!

Either select Text, and then Single Line Text, under the Draw Menu or type dtext at a Command: prompt.

When the prompt reads: Specify start point of text or [Justify/Style]:, type 2,2 and Enter to locate the LEFT LOWER CORNER of the text.

A"rubber band" like line should appear at this position. If the position is in the wrong place (See FIGURE 9) then press the Esc key to exit the command and start again.

When the prompt reads Specify height: <2.5>:, type 3 and press Enter.

When the prompt reads Specify Rotation angle of text <0>:, press Enter to select the default value and maintain the text's horizontal orientation.

If the "rubber band" appears to be in the correct position, type (in all CAPS) the text COURSE: GC 120 (or your appropriate course designation) and then press Enter until you are back to the Command: prompt.

Press Enter again to reactivate the Dtext command. AutoCAD remembers the last command you used.

When the prompt asks for a start point, use 2,9.

Notice that the Specify height: prompt already displays <3>, which is the height you entered for the last text. AutoCAD remembers the last parameters you entered for a command and will use them again if you press Enter.
Press Enter to accept the text height. Notice that the Rotation is still set to 0 degrees, so you can simply press the Enter key again.

When the " rubber band" line appears, type in DRAWN BY: YOUR NAME (type your own name) and Enter.

Now, you will add text in the same manner in several more places.

Activate the Dtext: command.

For position 72,2 type in SECTION: and your class section number.

For position 133,9 type in TITLE:.

For position 133,2 type in SCALE:.

For position 202,2 type in DATE:, but DO NOT add today's date. This is a template, and you will change the date for each tutorial.

Now, change back to the 0 Layer.

Return to a Command: prompt and Save.

See FIGURE 9.
[image: image17]
FIGURE 9 

Step 9

Before you print your titleblock, you need to turn it into a BLOCK or grouped item that you can insert into Layout 1 Since you are creating this file to use as a template for your other drawing, it makes sense for your titleblock to already be in the file. This saves you a lot of work, and I know you will like that.
The BLOCK command allows you to select part or all of a drawing, group it, and reuse it over and over. This is similar to the Copy and Paste commands you find in many programs, except that you do not have to copy it again since a Block is stored in the file. For example, if you were drawing elevations of a building with several identical windows, you only have to draw one window, and convert it to a block. Once it is a block, you can use the INSERT command to "paste" copies of the window into the elevation without redrawing it. Since you can use INSERT to place as many copies of a Block as you need, creating a big building with lots of windows is no sweat!

To turn the Titleblock into a Block, first change to the 0 layer by clicking on the arrow next to the Layer Status Window and selecting it. The 0 layer should now show in the Layer Status Window.

Now, type the word block at a Command: prompt and press Enter
or

select Block and then Make, on the Draw menu. A dialogue box will appear. See Figure 10.

In this dialogue box, first locate the Name: window and type Titleblock (each block must have an assigned name). 

Under the heading Objects, click on the Select objects button. AutoCAD will return you to the drawing screen so that you can select the lines and text that make up the titleblock. HINT: The easiest way to select the entire titleblock is to place the cursor so that it is just outside of one corner of the titleblock and then click the Left mouse button once. Next, slide the cursor just past the opposite diagonal corner of the titleblock and click the Left button again. Press the Enter key to return to the Block dialogue box. 

The next item in the Block dialogue box that you need to select is the block's Basepoint. 

A Basepoint is the position on the block that AutoCAD will use when inserting it into a MODEL or PAPER Space. For instance, in our earlier example of the building window block, the basepoint on the window probably should be one of the corners of the window drawing. This would help you accurately place the drawing of the window when you inserted into an elevation. 

Under the heading Basepoint, you can click on the Pick point button or type absolute coordinates into the X, Y, and Z windows below this. If you select the Pick point option, AutoCAD will again return you to the drawing screen so that you can select the basepoint of the block. For our purposes, you will see that the X, Y, and Z coordinates are already set to 0, so you can just click on OK to complete the block.

Now, ERASE the titleblock and its text. Don't worry, you already have a copy of it stored as a block, and, if you goof up, remember that you can use the Undo command to get back to the point that it appears in MODEL Space again.

Step 10
You are now ready to INSERT the titleblock into Layout 1 so that it can be printed from there. 

If you look towards the bottom of the AutoCAD screen, you will see three tabs labeled, Model, Layout 1, and Layout 2. Up until now, you have been working in MODEL Space. This is the space where you create drawings and models. MODEL Space is three-dimensional space. You can only have One MODEL Space in an AutoCAD file. Layouts, in contrast to MODEL Space, are referred to as PAPER Space, because they represent the PAPER on which you print your drawing. Layouts can be configured for different paper sizes and units, and, unlike MODEL Space, you can add additional Layouts to a file. 

Click on the tab at the bottom of the screen to access Layout 1[image: image18]. The Page Setup dialogue box for Layout 1 may appear, since this is the first time you have used Layout 1. See Figure 11. Make sure that the options in this dialogue box match the ones in Figure 11 and then click on OK. [image: image19]
FIGURE 11
Once the Page Setup box closes, the white Layout 1 screen can be seen. Inside of this layout you will see a continuous line rectangle with the titleblock inside and a dash line rectangle. Layout or PAPER Space is like a sheet of opaque paper. A window (Viewport) usually is cut in the paper so that a drawing or model in MODEL Space shows through and can be printed. However, we wish to actually place the Titleblock on Layout 1.With the titleblock on Layout 1, you can cut Viewport in it so a drawing created in Model Space will appear to be inside of the titleblock. AutoCAD allows you to do this. For that reason, you must remove the viewport that AutoCAD automatically cuts in Paper Space because we are not going to use the model space representative of the titleblock. 

To remove the Viewport, simply click on the continous line rectangle that surrounds the titleblock and then either click on the ERASE button [image: image20]or type e (the alias for Erase) at a Command: prompt and then press the Enter key. The titleblock will disappear, and only the dash line will remain. Viewports in PAPER Space can be effected by some of the same tools that you use for creating and modifying a drawing. Layout 1 is now ready to have the titleblock inserted. 

To INSERT the titleblock, select Block... on the Insert Menu. See figure to the right. Since the Titleblock is the only block you have, it will already be displayed in the Name: window. If you had more than one block, you could use the arrow to the Right of the Name: window to select the block you wish to insert. 

Before you exit the Insert dialogue box, notice that it also has a Browse button. This button allows you to locate a file and insert a drawing located in one file into another file.

To exit the Insert dialogue box, click on OK. You will return to the Layout 1 screen. The titleblock will appear in the Layout 1 screen, but can be moved by dragging the cursor. Slide the cursor until the titleblock looks about centered in the dashed line and click the Left mouse button to insert it at that position. Do not worry about getting it perfectly centered. We will deal with that during printing.

This would be a good time of save your file!!! 

Step 11
You are now ready to print your titleblock; however, the first thing you must do is set the printer at your location as the default. The printer defaults to Acrobat Reader on the campus computer network. 

To select the printer select the Start button with the Left mouse button and slide up to Settings... to display the Settings flyout menu. On this menu, use the LEFT mouse button to click on the Printer selection. A Printer dialogue box will appear. Click on the printer that is at your location with the RIGHT mouse button so that a pop-up menu appears. Select Set as Default on this pop-up menu. Note: You will have to do this every time you start a new computer session. The default printer will revert to Acrobat Reader when you logout.
Printing in AutoCAD is accomplished through the Plot command.

To activate this command, click on Print under the File pull-down menu

OR

type plot or print and Enter at the Command: prompt

OR

click on the Printer [image: image21]button.

The Plot Device/Plot Settings dialogue box should appear.

Inside the Plot Device dialogue box, find the Name: window. Use the arrow, on the Right side of this window, to select the name of the printer at your location. It should now show in the Name: window. 

Now click on the Plot Settings tab to move to that dialogue box. Inside the Plot Settings dialogue box make sure that these items are selected (see FIGURE 12):

-In the radio button under the heading Paper size make sure that mm is selected. 

-In the window next to the heading Paper size, use the drop down menu to select A4 size paper is showing or make sure that it is displayed.

-Under the heading Drawing orientation, make sure that the radio button next to Landscape is selected. 

-Under the heading Plot area, select Extents by clicking on the radio button next to that category. This tells AutoCAD to print to the "extent" of the drawing.

-If not already selected, use the drop-down menu next to Scale to change the scale to 1:1.

-Under the heading Plot offset, click on the check box to the left of the label: Center the plot.

-Under the Plot Options heading, remove the check by Plot with Plot Styles.

[image: image22]
Click on the Full button, at the bottom of the dialogue box, to examine the way your file will look when it is printed.

To EXIT Print Preview - Click the RIGHT mouse button on the screen and a pop-up dialogue box will appear. Drag down to EXIT, and you will be returned to the Plot configuration dialogue box.

-If the drawing appeared to be correct in Full Preview, click on the OK button to send it to the printer. See Figure 13.

[image: image23]
Figure 13
Save your drawing again (using Save As from the file menu as: “North Arrow”.  Inside the drawing frame draw a north arrow (a box arrow pointing north!).  Add your name and title, scale and date information to your drawing.  Save and print out.
To exit AutoCAD, either type quit at a Command: prompt or select Exit under the File menu. 

You should always exit AutoCAD properly.
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